summaryrefslogtreecommitdiff
path: root/ext/chromaprint/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/chromaprint/Makefile.am')
-rw-r--r--ext/chromaprint/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/ext/chromaprint/Makefile.am b/ext/chromaprint/Makefile.am
new file mode 100644
index 000000000..115d8c298
--- /dev/null
+++ b/ext/chromaprint/Makefile.am
@@ -0,0 +1,14 @@
+plugin_LTLIBRARIES = libgstchromaprint.la
+
+libgstchromaprint_la_SOURCES = gstchromaprint.c gstchromaprint.h
+
+libgstchromaprint_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
+ $(CHROMAPRINT_CFLAGS)
+libgstchromaprint_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(GST_LIBS) \
+ $(CHROMAPRINT_LIBS)
+libgstchromaprint_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstchromaprint_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstchromaprint.h