summaryrefslogtreecommitdiff
path: root/ext/chromaprint/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2012-01-25 13:22:43 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2012-01-25 13:22:43 +0100
commita2a430024136fd947637ff56a4fea6a2689ca59d (patch)
tree8cab3177242814f02b1e49a51d81b5f2f1660621 /ext/chromaprint/Makefile.am
parent071c6e8f15f2afff7ca4ce5934c3bae1d76aea95 (diff)
parent8fb0beaf00aeae2ef6081d08f0d74d6e655a53da (diff)
Merge branch 'master' into 0.11
Conflicts: configure.ac ext/kate/gstkateenc.c gst/colorspace/colorspace.c gst/mpegvideoparse/mpegvideoparse.c
Diffstat (limited to 'ext/chromaprint/Makefile.am')
-rw-r--r--ext/chromaprint/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/ext/chromaprint/Makefile.am b/ext/chromaprint/Makefile.am
new file mode 100644
index 000000000..115d8c298
--- /dev/null
+++ b/ext/chromaprint/Makefile.am
@@ -0,0 +1,14 @@
+plugin_LTLIBRARIES = libgstchromaprint.la
+
+libgstchromaprint_la_SOURCES = gstchromaprint.c gstchromaprint.h
+
+libgstchromaprint_la_CFLAGS = $(GST_PLUGINS_BAD_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
+ $(CHROMAPRINT_CFLAGS)
+libgstchromaprint_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(GST_LIBS) \
+ $(CHROMAPRINT_LIBS)
+libgstchromaprint_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstchromaprint_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstchromaprint.h