summaryrefslogtreecommitdiff
path: root/clients/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-01-14 20:38:35 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-01-14 20:38:35 -0500
commita1015b9e8c135820080549006c61a8450aca688f (patch)
tree159f4f66f5e7204b83ebf7883c074f44cee61721 /clients/Makefile.am
parentbe63ae5a2c3516e35f17b33bda41df3d09d661eb (diff)
Link simple-client against libGLESv2.so, not full GL
Diffstat (limited to 'clients/Makefile.am')
-rw-r--r--clients/Makefile.am44
1 files changed, 30 insertions, 14 deletions
diff --git a/clients/Makefile.am b/clients/Makefile.am
index 9f9ceca..a259b6a 100644
--- a/clients/Makefile.am
+++ b/clients/Makefile.am
@@ -12,18 +12,13 @@ noinst_PROGRAMS = \
noinst_LTLIBRARIES = libtoytoolkit.la
-INCLUDES = \
+AM_CFLAGS = $(GCC_CFLAGS)
+AM_CPPFLAGS = \
+ -DDATADIR='"$(datadir)"' \
-I$(top_srcdir)/wayland \
- -I$(top_builddir)/wayland \
+ -I$(top_builddir)/wayland \
$(CLIENT_CFLAGS)
-LDADD = libtoytoolkit.la \
- $(top_builddir)/wayland/libwayland-client.la \
- $(CLIENT_LIBS) -lrt -lm
-
-AM_CFLAGS = $(GCC_CFLAGS)
-AM_CPPFLAGS = -DDATADIR='"$(datadir)"'
-
libtoytoolkit_la_SOURCES = \
window.c \
window.h \
@@ -32,15 +27,38 @@ libtoytoolkit_la_SOURCES = \
cairo-util.c \
cairo-util.h
-flower_SOURCES = flower.c
-smoke_SOURCES = smoke.c
+toolkit_libs = \
+ libtoytoolkit.la \
+ $(top_builddir)/wayland/libwayland-client.la \
+ $(CLIENT_LIBS) -lrt -lm
+
gears_SOURCES = gears.c
+gears_LDADD = $(toolkit_libs)
+
+flower_SOURCES = flower.c
+flower_LDADD = $(toolkit_libs)
+
screenshot_SOURCES = screenshot.c screenshooter-protocol.c
+screenshot_LDADD = $(toolkit_libs)
+
terminal_SOURCES = terminal.c
+terminal_LDADD = $(toolkit_libs) -lutil
+
image_SOURCES = image.c
+image_LDADD = $(toolkit_libs)
+
dnd_SOURCES = dnd.c
+dnd_LDADD = $(toolkit_libs)
+
+smoke_SOURCES = smoke.c
+smoke_LDADD = $(toolkit_libs)
+
resizor_SOURCES = resizor.c
+resizor_LDADD = $(toolkit_libs)
+
simple_client_SOURCES = simple-client.c
+simple_client_LDADD = \
+ $(top_builddir)/wayland/libwayland-client.la -lm $(GLES2_LIBS)
BUILT_SOURCES = \
screenshooter-client-protocol.h \
@@ -50,11 +68,9 @@ CLEANFILES = $(BUILT_SOURCES)
include $(top_srcdir)/wayland/scanner.mk
-terminal_LDADD = $(LDADD) -lutil
-
if HAVE_POPPLER
poppler_programs = view
view_SOURCES = view.c
-view_LDADD = $(LDADD) $(POPPLER_LIBS)
+view_LDADD = $(toolkit_libs) $(POPPLER_LIBS)
view_CPPFLAGS = $(POPPLER_CFLAGS)
endif