summaryrefslogtreecommitdiff
path: root/gst/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/Makefile.am')
-rw-r--r--gst/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gst/Makefile.am b/gst/Makefile.am
index 7eb12251f..c1bdf0c16 100644
--- a/gst/Makefile.am
+++ b/gst/Makefile.am
@@ -260,7 +260,9 @@ if HAVE_INTROSPECTION
BUILT_GIRSOURCES = Gst-@GST_API_VERSION@.gir
gir_headers=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_API_VERSION@include_HEADERS))
+gir_headers+=$(patsubst %,$(builddir)/%, $(built_header_make))
gir_sources=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_API_VERSION@_la_SOURCES))
+gir_sources+=$(patsubst %,$(builddir)/%, $(built_source_make))
Gst-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstreamer-@GST_API_VERSION@.la
$(AM_V_GEN)GST_PLUGIN_SYSTEM_PATH_1_0="" GST_PLUGIN_PATH_1_0="" GST_REGISTRY_UPDATE=no \