summaryrefslogtreecommitdiff
path: root/gst/Makefile.am
diff options
context:
space:
mode:
authorSimon Feltman <sfeltman@src.gnome.org>2013-01-27 06:20:51 -0800
committerTim-Philipp Müller <tim@centricular.net>2013-01-27 20:55:38 +0000
commitd2b03a45371900e3100209b5fa4d3412b23aef94 (patch)
treef912de6c6748bfc66142ee863f1f555c1bf7ba79 /gst/Makefile.am
parent9fddb6c3cd4be6efaef33c7fd5e1cd7449e6ecd0 (diff)
g-i: add built enumtypes headers and sources to gir creation
Add gstenumtypes.h/c for inclusion with g-ir-scanner. This fixes problems where introspection based bindings think GstState is typeless due to the GType not being included as an annotation. https://bugzilla.gnome.org/show_bug.cgi?id=691185
Diffstat (limited to 'gst/Makefile.am')
-rw-r--r--gst/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gst/Makefile.am b/gst/Makefile.am
index 7eb12251f..c1bdf0c16 100644
--- a/gst/Makefile.am
+++ b/gst/Makefile.am
@@ -260,7 +260,9 @@ if HAVE_INTROSPECTION
BUILT_GIRSOURCES = Gst-@GST_API_VERSION@.gir
gir_headers=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_API_VERSION@include_HEADERS))
+gir_headers+=$(patsubst %,$(builddir)/%, $(built_header_make))
gir_sources=$(patsubst %,$(srcdir)/%, $(libgstreamer_@GST_API_VERSION@_la_SOURCES))
+gir_sources+=$(patsubst %,$(builddir)/%, $(built_source_make))
Gst-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstreamer-@GST_API_VERSION@.la
$(AM_V_GEN)GST_PLUGIN_SYSTEM_PATH_1_0="" GST_PLUGIN_PATH_1_0="" GST_REGISTRY_UPDATE=no \