summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-06-21 08:35:03 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-06-22 09:51:25 -0700
commit94cf3970925ec87d913a1549a42cdb03713fc4bb (patch)
treebca9e9b204c2f231c66caaa9db8b6c8629990783 /meson.build
parenta6943bb4ce99ea7af7222552f1326fb80823d0b2 (diff)
meson: Fix auto option for va
The same as the previous two patches, but for the libva state tracker. Fixes: 724916c8a84b5bba8f880f17da936585d52c97b6 ("meson: dedup gallium-xvmc logic") Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 9 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 82e2b535254..e88616c9e82 100644
--- a/meson.build
+++ b/meson.build
@@ -559,13 +559,16 @@ elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
elif _va == 'auto'
_va = 'true'
endif
-with_gallium_va = _va == 'true'
+with_gallium_va = false
dep_va = null_dep
-if with_gallium_va
- dep_va = dependency('libva', version : '>= 0.39.0')
- dep_va_headers = declare_dependency(
- compile_args : run_command(prog_pkgconfig, ['libva', '--cflags']).stdout().split()
- )
+if _va != 'false'
+ dep_va = dependency('libva', version : '>= 0.38.0', required : _va == 'true')
+ if dep_va.found()
+ dep_va_headers = declare_dependency(
+ compile_args : run_command(prog_pkgconfig, ['libva', '--cflags']).stdout().split()
+ )
+ with_gallium_va = true
+ endif
endif
va_drivers_path = get_option('va-libs-path')