summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-06-21 08:34:05 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-06-22 09:51:18 -0700
commita6943bb4ce99ea7af7222552f1326fb80823d0b2 (patch)
treef2c633a382a8b12dcddf659cc1bfb86ba5ebb89c /meson.build
parentd9a8008a93d87287b696627ea6dd01b278b6d579 (diff)
meson: Fix auto option for xvmc
This fixes the same problem as the previous patch did for vdpau, but for xvmc. Fixes: 724916c8a84b5bba8f880f17da936585d52c97b6 ("meson: dedup gallium-xvmc logic") Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 429865c9442..82e2b535254 100644
--- a/meson.build
+++ b/meson.build
@@ -438,13 +438,12 @@ elif not (with_gallium_r600 or with_gallium_nouveau)
else
_xvmc = 'false'
endif
-elif _xvmc == 'auto'
- _xvmc = 'true'
endif
-with_gallium_xvmc = _xvmc == 'true'
dep_xvmc = null_dep
-if with_gallium_xvmc
- dep_xvmc = dependency('xvmc', version : '>= 1.0.6')
+with_gallium_xvmc = false
+if _xmvc != 'false'
+ dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'true')
+ with_gallium_xvmc = dep_xvmc.found()
endif
xvmc_drivers_path = get_option('xvmc-libs-path')