summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2009-07-21 20:38:53 -0700
committerEric Anholt <eric@anholt.net>2009-07-21 20:54:37 -0700
commit64575ce8f515b6c2f997ebe509f858cb4d384c50 (patch)
treed109a640194ece0fd439a34246a127cfe497d895 /configure.ac
parentb2ab26e1d95bda557517a73d67c9cc0aa2514e5e (diff)
Use SDL instead of GLUT.
Cribbed thoroughly from idr's stuff.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7c17e32..56f84ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,11 +46,11 @@ WARN_CFLAGS=""
if test "x$GCC" = "xyes"; then
WARN_CFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations \
- -Wnested-externs -fno-strict-aliasing"
+ -Wnested-externs -fno-strict-aliasing -Wno-switch-enum"
fi
AC_SUBST([WARN_CFLAGS])
-PKG_CHECK_MODULES(GL, [gl])
+PKG_CHECK_MODULES(GL, [gl sdl])
GL_LIBS="$GL_LIBS -lGLEW"
dnl libpng check, taken from cairo. Yuck.