summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2011-08-07 14:46:35 +0100
committerKenneth Graunke <kenneth@whitecape.org>2011-08-07 15:18:29 -0700
commit72a0432e1adee743dc2e7441cc52c7c14a0e611f (patch)
tree32d791d16f1a1e7ea6372b99ea7c14a25341f7b8 /Makefile.am
parentea28a79de4eb4b2b5dc270acfc2f12b5ec76cda1 (diff)
Use -no-undefined libtool flag, fix underlinking with --enable-motif
Use -no-undefined to assure libtool that the library has no unresolved symbols at link time, so that libtool will build a shared library on platforms require that all symbols are resolved when the library is linked. This exposes the fact that we are underlinked when ./configured with --enable-motif, so also link with motif libs in that case. Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f8bb04..b95438c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,7 @@ lib_LTLIBRARIES = libGLw.la
libGLw_la_SOURCES = GLwDrawA.c
libGLw_la_CFLAGS = $(GLW_CLFAGS)
libGLw_la_LIBADD = $(GLW_LIBS)
-libGLw_la_LDFLAGS = -version-info $(GLW_LIBRARY_VERSION)
+libGLw_la_LDFLAGS = -version-info $(GLW_LIBRARY_VERSION) -no-undefined
if ENABLE_MOTIF
libGLw_la_SOURCES += GLwMDrawA.c
libGLw_la_CFLAGS += $(MOTIF_CFLAGS)