summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2011-08-03 13:08:00 -0700
committerKenneth Graunke <kenneth@whitecape.org>2011-08-05 16:31:17 -0700
commitea28a79de4eb4b2b5dc270acfc2f12b5ec76cda1 (patch)
treed5615c63d5ecf965fe932799829c8640deb39932 /Makefile.am
parent9a10f52f031045150c6e1d3a1e7a7266d530333b (diff)
Convert build system to GNU autotools.
Now that glw doesn't live inside Mesa, it needs its own build system. We may as well use GNU autotools. Also add a .gitignore file. Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..4f8bb04
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+# Copyright © 2011 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+AUTOMAKE_OPTIONS = foreign
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = glw.pc
+
+GLW_LIBRARY_VERSION=1:0:0
+lib_LTLIBRARIES = libGLw.la
+libGLw_la_SOURCES = GLwDrawA.c
+libGLw_la_CFLAGS = $(GLW_CLFAGS)
+libGLw_la_LIBADD = $(GLW_LIBS)
+libGLw_la_LDFLAGS = -version-info $(GLW_LIBRARY_VERSION)
+if ENABLE_MOTIF
+libGLw_la_SOURCES += GLwMDrawA.c
+libGLw_la_CFLAGS += $(MOTIF_CFLAGS)
+libGLw_la_LIBADD += $(MOTIF_LIBS)
+endif
+library_includedir=$(includedir)/GL/
+library_include_HEADERS=GLwDrawA.h GLwDrawAP.h GLwMDrawA.h GLwMDrawAP.h
+
+clean:
+ -rm -f *.o *.lo *.la *~
+ -rm -rf .libs