summaryrefslogtreecommitdiff
path: root/lib/loudmouth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/loudmouth/Makefile.am')
-rw-r--r--lib/loudmouth/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/lib/loudmouth/Makefile.am b/lib/loudmouth/Makefile.am
index 7859c2c5..d7853803 100644
--- a/lib/loudmouth/Makefile.am
+++ b/lib/loudmouth/Makefile.am
@@ -1,5 +1,3 @@
-include $(top_srcdir)/tools/shave.mk
-
noinst_LTLIBRARIES = libloudmouth.la
BUILT_SOURCES = \
@@ -35,11 +33,11 @@ dist-hook:
$(shell for x in $(BUILT_SOURCES); do rm -f $(distdir)/$$x ; done)
loudmouth-signals-marshal.list: $(OUR_SOURCES) Makefile.am
- $(QUIET_GEN)( cd $(srcdir) && \
+ $(AM_V_GEN)( cd $(srcdir) && \
sed -n -e 's/.*_loudmouth_signals_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
$(OUR_SOURCES) ) \
| sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
- if cmp -s $@.tmp $@; then \
+ @if cmp -s $@.tmp $@; then \
rm $@.tmp; \
touch $@; \
else \
@@ -47,10 +45,10 @@ loudmouth-signals-marshal.list: $(OUR_SOURCES) Makefile.am
fi
%-signals-marshal.h: %-signals-marshal.list Makefile.am
- $(QUIET_GEN)glib-genmarshal --header --prefix=_$(subst -,_,$*)_signals_marshal $< > $@
+ $(AM_V_GEN)glib-genmarshal --header --prefix=_$(subst -,_,$*)_signals_marshal $< > $@
%-signals-marshal.c: %-signals-marshal.list Makefile.am
- $(QUIET_GEN){ echo '#include "$*-signals-marshal.h"' && \
+ $(AM_V_GEN){ echo '#include "$*-signals-marshal.h"' && \
glib-genmarshal --body --prefix=_$(subst -,_,$*)_signals_marshal $< ; \
} > $@
@@ -61,7 +59,7 @@ AM_LDFLAGS = $(GCOV_LIBS) @GLIB_LIBS@ @RESOLV_LIBS@ @WOCKY_LIBS@
# rules for making the glib enum objects
%-enumtypes.h: %.h Makefile.in
- $(QUIET_GEN)glib-mkenums \
+ $(AM_V_GEN)glib-mkenums \
--fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
--fprod "/* enumerations from \"@filename@\" */\n" \
--vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
@@ -69,7 +67,7 @@ AM_LDFLAGS = $(GCOV_LIBS) @GLIB_LIBS@ @RESOLV_LIBS@ @WOCKY_LIBS@
$< > $@
%-enumtypes.c: %.h Makefile.in
- $(QUIET_GEN)glib-mkenums \
+ $(AM_V_GEN)glib-mkenums \
--fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \