summaryrefslogtreecommitdiff
path: root/Xext/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2006-02-16 07:17:31 +0000
committerKeith Packard <keithp@keithp.com>2006-02-16 07:17:31 +0000
commit8987b2c1efc9a4667e278e6ba411772ba2a4a4e6 (patch)
treeeb7aa732b0f74c958770e26717679c8e893449bc /Xext/Makefile.am
parentc8acb342695936db062c966029019a458d45459e (diff)
Make more extensions optional in build (for kdrive). Fix kdrive build for
actual hardware. Fix kdrive pointer signed/unsigned types. Add kdrive-required YX rotation functions. Replace rgb text file loading with static rgb color table.
Diffstat (limited to 'Xext/Makefile.am')
-rw-r--r--Xext/Makefile.am29
1 files changed, 23 insertions, 6 deletions
diff --git a/Xext/Makefile.am b/Xext/Makefile.am
index b991958cf..c62e75410 100644
--- a/Xext/Makefile.am
+++ b/Xext/Makefile.am
@@ -4,7 +4,11 @@
# Xorg by default
# libXextmodule.la: includes those extensions that are built into a module
# that Xorg loads
+if XORG
noinst_LTLIBRARIES = libXext.la libXextbuiltin.la libXextmodule.la
+else
+noinst_LTLIBRARIES = libXext.la
+endif
INCLUDES = -I$(top_srcdir)/hw/xfree86/dixmods/extmod
@@ -22,8 +26,7 @@ BUILTIN_SRCS = \
xtest.c \
xtest1di.c \
xtest1dd.c \
- xtest1dd.h \
- xf86bigfont.c
+ xtest1dd.h
# Sources always included in libXextmodule.la & libXext.la
MODULE_SRCS = \
@@ -31,9 +34,7 @@ MODULE_SRCS = \
mitmisc.c \
shape.c \
sync.c \
- xcmisc.c \
- dpms.c \
- dpmsproc.h
+ xcmisc.c
# Optional sources included if extension enabled by configure.ac rules
@@ -123,13 +124,27 @@ if FONTCACHE
MODULE_SRCS += $(FONTCACHE_SRCS)
endif
+# XF86 Big Font extension
+BIGFONT_SRCS = xf86bigfont.c
+if XF86BIGFONT
+MODULE_SRCS += $(BIGFONT_SRCS)
+endif
+
+# DPMS extension
+DPMS_SRCS = dpms.c dpmsproc.h
+if DPMSExtension
+MODULE_SRCS += $(DPMS_SRCS)
+endif
+
# Now take all of the above, mix well, bake for 10 minutes and get libXext*.la
libXext_la_SOURCES = $(BUILTIN_SRCS) $(MODULE_SRCS)
+if XORG
libXextbuiltin_la_SOURCES = $(BUILTIN_SRCS)
libXextmodule_la_SOURCES = $(MODULE_SRCS)
+endif
EXTRA_DIST = \
README.xtest1-ddx \
@@ -147,5 +162,7 @@ EXTRA_DIST = \
$(EVI_SRCS) \
$(MULTIBUFFER_SRCS) \
$(EXTRA_MULTIBUFFER_SRCS) \
- $(FONTCACHE_SRCS)
+ $(FONTCACHE_SRCS) \
+ $(BIGFONT_SRCS) \
+ $(DPMS_SRCS)