summaryrefslogtreecommitdiff
path: root/fixesproto/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2010-04-06 14:17:29 -0700
committerKeith Packard <keithp@keithp.com>2010-04-06 14:17:29 -0700
commit4b1fd946b476aad3b5a11b834726265372a36ff5 (patch)
treebe8262b689d870cba2af22cf6f48bbbee5b79b24 /fixesproto/configure.ac
parent7e8529bc470ea0fbfb28cf40b46644f988393bb6 (diff)
parent1451dfc4df7dfa51cc28062096093b0f4d3e1439 (diff)
Merge remote branch 'fixesproto/master'
Diffstat (limited to 'fixesproto/configure.ac')
-rw-r--r--fixesproto/configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/fixesproto/configure.ac b/fixesproto/configure.ac
new file mode 100644
index 0000000..04a9feb
--- /dev/null
+++ b/fixesproto/configure.ac
@@ -0,0 +1,37 @@
+dnl
+dnl Copyright © 2003 Keith Packard, Noah Levitt
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Keith Packard not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Keith Packard makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.60])
+AC_INIT([FixesProto], [4.1.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
+
+AC_OUTPUT([Makefile
+ fixesproto.pc])
+