summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-10-03 11:56:18 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-10-03 11:56:18 +0200
commit2703f4144df261be2f93f256d9bc616fb4b617d6 (patch)
tree976bbfe8af287f3333deebb75c122d42a60ba942 /configure.ac
parent276a73c1e1804dd507a006b7666e8984c8a74727 (diff)
debian: split libva packages based on the implemented API.
Align with OSVs (Ubuntu, Debian) for libva package names. i.e. split the main libva1 package into Core (libva1) and as many packages as there are backends enabled configure/dist time. Signed-off-by: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 20 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 287fd6e..da98f06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,9 @@ m4_define([libva_lt_age],
# libdrm minimun version requirement
m4_define([libdrm_version], [2.4])
+# Wayland minimum version number
+m4_define([wayland_api_version], [0.95.0])
+
AC_PREREQ(2.57)
AC_INIT([libva], [libva_version], [waldo.bastian@intel.com], libva)
AC_CONFIG_SRCDIR([Makefile.am])
@@ -259,9 +262,13 @@ fi
AM_CONDITIONAL(USE_EGL, test "$USE_EGL" = "yes")
# Check for Wayland
+WAYLAND_API_VERSION=wayland_api_version
+AC_SUBST(WAYLAND_API_VERSION)
+
USE_WAYLAND="no"
if test "$enable_wayland" = "yes"; then
- PKG_CHECK_MODULES([WAYLAND], [wayland-client], [USE_WAYLAND="yes"], [:])
+ PKG_CHECK_MODULES([WAYLAND], [wayland-client >= wayland_api_version],
+ [USE_WAYLAND="yes"], [:])
if test "$USE_WAYLAND" = "yes"; then
AC_DEFINE([HAVE_VA_WAYLAND], [1],
[Defined to 1 if VA/Wayland API is built])
@@ -288,6 +295,16 @@ AC_OUTPUT([
debian.upstream/control
debian.upstream/libva$LIBVA_MAJOR_VERSION.install:\
debian.upstream/libva.install.in
+ debian.upstream/libva-drm$LIBVA_MAJOR_VERSION.install:\
+debian.upstream/libva-drm.install.in
+ debian.upstream/libva-egl$LIBVA_MAJOR_VERSION.install:\
+debian.upstream/libva-egl.install.in
+ debian.upstream/libva-glx$LIBVA_MAJOR_VERSION.install:\
+debian.upstream/libva-glx.install.in
+ debian.upstream/libva-wayland$LIBVA_MAJOR_VERSION.install:\
+debian.upstream/libva-wayland.install.in
+ debian.upstream/libva-x11-$LIBVA_MAJOR_VERSION.install:\
+debian.upstream/libva-x11.install.in
doc/Makefile
dummy_drv_video/Makefile
pkgconfig/Makefile
@@ -304,10 +321,10 @@ debian.upstream/libva.install.in
test/decode/Makefile
test/encode/Makefile
test/putsurface/Makefile
- test/vainfo/Makefile
test/v4l_h264/Makefile
- test/v4l_h264/encode/Makefile
test/v4l_h264/decode/Makefile
+ test/v4l_h264/encode/Makefile
+ test/vainfo/Makefile
va/Makefile
va/drm/Makefile
va/egl/Makefile