summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2009-05-24 15:55:06 -0700
committerDavid Schleef <ds@schleef.org>2009-05-24 15:55:06 -0700
commit534dbcd277be736414af37590d4af4e3dfe70575 (patch)
tree9a1d0bd1fc8f7df7983901f54f487201483d7fe2 /testsuite/Makefile.am
parent4fac67acd462c4b994a405448e6c2abf6875cfcb (diff)
tests: fix up tests for new api
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index 8d5d0b1..ee30e71 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -1,11 +1,16 @@
-TESTS = compile_opcodes_c \
+TESTS = \
+ compile_opcodes_sys_c \
+ compile_opcodes_float_c \
+ compile_opcodes_pixel_c \
test_accsadubl test-schro \
compile_opcodes_sys exec_opcodes_sys \
compile_opcodes_float exec_opcodes_float \
compile_opcodes_pixel exec_opcodes_pixel
XFAIL_TESTS = \
+ compile_opcodes_float_c \
+ compile_opcodes_pixel_c \
exec_opcodes_float \
exec_opcodes_pixel
@@ -16,11 +21,15 @@ CLEANFILES = temp-orc-test-*
AM_CFLAGS = $(ORC_CFLAGS)
LIBS = $(ORC_LIBS) $(top_builddir)/orc-test/liborc-test-0.3.la
+compile_opcodes_float_c_LDADD = \
+ $(top_builddir)/orc-float/liborc-float-0.3.la
compile_opcodes_float_LDADD = \
$(top_builddir)/orc-float/liborc-float-0.3.la
exec_opcodes_float_LDADD = \
$(top_builddir)/orc-float/liborc-float-0.3.la
+compile_opcodes_pixel_c_LDADD = \
+ $(top_builddir)/orc-pixel/liborc-pixel-0.3.la
compile_opcodes_pixel_LDADD = \
$(top_builddir)/orc-pixel/liborc-pixel-0.3.la
exec_opcodes_pixel_LDADD = \