summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-07-31 15:20:32 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-07-31 15:20:32 +0000
commit4bfb1fe70c6f0d5e29c17a8eeffb02f7fd083f11 (patch)
tree6719ce6a0a30d55bddd1b39067f249795ad88784 /plugins/Makefile.am
parentb491e19e0e15cb4d420084e53b13a5aa443487a6 (diff)
Remove GST_DISABLE_(ENUMTYPES|INDEX|URI) everywhere.
Original commit message from CVS: * configure.ac: * docs/gst/gstreamer-sections.txt: * docs/gst/gstreamer.types: * docs/gst/gstreamer.types.in: * gst/Makefile.am: * gst/gst.c: * gst/gstbin.c: (gst_bin_class_init), (gst_bin_set_index_func): * gst/gstconfig.h.in: * gst/gstelement.c: (gst_element_get_index): * gst/gstregistrybinary.c: (gst_registry_binary_save_feature), (gst_registry_binary_load_feature), (gst_registry_binary_read_cache): * gst/gstregistryxml.c: (load_feature), (gst_registry_xml_read_cache), (gst_registry_xml_save_feature): * plugins/Makefile.am: * tools/gst-indent: * tools/gst-inspect.c: (print_index_info), (print_element_list), (print_plugin_features), (print_element_features): * tools/gst-xmlinspect.c: (print_event_masks), (print_element_info): * win32/common/gstconfig.h: Remove GST_DISABLE_(ENUMTYPES|INDEX|URI) everywhere. Disabling the indexers and URI handler code will only reduce the required amount of memory by a very small amount but on the other hand requires much more maintaince work. Apart from that many places of code are broken when disabling them. Disabling the enum types doesn't reduce the required amount of memory by more than a few bytes and makes it hard to fix bugs like #539772, i.e. use the enums as GObject properties.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index f6ed61a77..90b658033 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,9 +1,3 @@
-if GST_DISABLE_INDEX
-SUBDIRS_INDEX =
-else
-SUBDIRS_INDEX = indexers
-endif
-
-SUBDIRS = elements $(SUBDIRS_INDEX)
+SUBDIRS = elements indexers
DIST_SUBDIRS = elements indexers