summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-06-27 09:02:51 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-06-27 09:02:51 +0000
commit5a01364a72b185c55e3af01bd58887e9b2c0195a (patch)
treee73206bd868869525cbeb45d7ec7760c34071e61 /configure.ac
parent4f92facc79cb6d3ea08947716bc8ad5a9d0f0697 (diff)
configure.ac:
Original commit message from CVS: * configure.ac: Show configuration sumary after configure run. Based on patch by Luc Pionchon <luc.pionchon@nokia.com>. Fixes: #540134
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c3d4fb20c..9634caea9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -695,3 +695,41 @@ gstreamer.spec
)
AC_OUTPUT
+
+dnl negate for output
+if test "x${GST_DISABLE_LOADSAVE}" = "xno"; then enable_loadsave="yes"; fi
+if test "x${GST_DISABLE_PARSE}" = "xno"; then enable_parse="yes"; fi
+if test "x${GST_DISABLE_OPTION_PARSING}" = "xno"; then enable_option_parsing="yes"; fi
+if test "x${GST_DISABLE_TRACE}" = "xno"; then enable_trace="yes"; fi
+if test "x${GST_DISABLE_ALLOC_TRACE}" = "xno"; then enable_alloc_trace="yes"; fi
+if test "x${GST_DISABLE_PLUGIN}" = "xno"; then enable_plugin="yes"; fi
+if test "x${GST_DISABLE_NET}" = "xno"; then enable_net="yes"; fi
+
+echo "
+
+Configuration
+ Version : ${VERSION}
+ Source code location : ${srcdir}
+ Prefix : ${prefix}
+ Compiler : ${CC}
+ Package name : ${GST_PACKAGE_NAME}
+ Package origin : ${GST_PACKAGE_ORIGIN}
+
+ Documentation (manuals) : ${enable_docbook}
+ Documentation (API) : ${enable_gtk_doc}
+
+ Pipeline XML load/save : ${enable_loadsave}
+ Command-line parser : ${enable_parse}
+ Option parsing in gst_init : ${enable_option_parsing}
+ Tracing subsystem : ${enable_trace}
+ Allocation tracing : ${enable_alloc_trace}
+ Plugin registry : ${enable_plugin}
+ Network support : ${enable_net}
+
+ Debug : ${USE_DEBUG}
+ Profiling : ${USE_PROFILING}
+
+ Building examples : ${BUILD_EXAMPLES}
+ Building test apps : ${BUILD_TESTS}
+ Building tests that fail : ${BUILD_FAILING_TESTS}
+"