summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2009-01-23 09:54:53 +0100
committerSebastian Dröge <slomo@circular-chaos.org>2009-01-23 09:54:53 +0100
commit0bf1bd0db059b5e2e51e9293cea72cfb557ac567 (patch)
tree8781250ae44aece3355c18aa494551d17f2659ad /configure.ac
parent1d3c1380bf1762ef80530e75971d804950ab1482 (diff)
Fix linking failures on Solaris. Fixes bug #568481.
Link libgstreamer with $(LIBM) as it uses math functions. Add a configure check for socket and nsl library and add them to LIBS if they're found. This is needed on Solaris for socket() and gethostbyname().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2409b478..10709dc96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -455,6 +455,10 @@ AC_CHECK_LIB(dl, dladdr,
LIBS="$LIBS -ldl")
CFLAGS="$save_cflags"
+dnl *** checks for socket and nsl libraries ***
+AC_CHECK_FUNC(socket,,[AC_CHECK_LIB(socket,socket)])
+AC_CHECK_FUNC(gethostbyname,,[AC_CHECK_LIB(nsl,gethostbyname)])
+
dnl check for inet_aton()
save_libs="$LIBS"
AC_CHECK_FUNC(inet_aton, ,