summaryrefslogtreecommitdiff
path: root/gst/rtsp-server/Makefile.am
diff options
context:
space:
mode:
authorSebastian Pölsterl <sebp@ubuntu.(none)>2008-11-13 19:43:10 +0100
committerWim Taymans <wim@wtay.(none)>2009-01-08 13:52:10 +0100
commita8400faeab513157c3e2140d93166239431308ea (patch)
treeddc57dd3df141176e6229efba84137429dfe24f5 /gst/rtsp-server/Makefile.am
parent36fb0de01c4f954f4f56751de8899643ac4e027b (diff)
Put GStreamer version in library name
Diffstat (limited to 'gst/rtsp-server/Makefile.am')
-rw-r--r--gst/rtsp-server/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/gst/rtsp-server/Makefile.am b/gst/rtsp-server/Makefile.am
index 7ae1175..8547149 100644
--- a/gst/rtsp-server/Makefile.am
+++ b/gst/rtsp-server/Makefile.am
@@ -15,18 +15,18 @@ noinst_HEADERS = \
rtsp-session.h
lib_LTLIBRARIES = \
- libgstrtspserver.la
+ libgstrtspserver-@GST_MAJORMINOR@.la
-libgstrtspserver_la_SOURCES = \
+libgstrtspserver_@GST_MAJORMINOR@_la_SOURCES = \
$(c_sources)
-libgstrtspserver_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
-libgstrtspserver_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-libgstrtspserver_la_LIBADD = \
+libgstrtspserver_@GST_MAJORMINOR@_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+libgstrtspserver_@GST_MAJORMINOR@_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstrtspserver_@GST_MAJORMINOR@_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) \
-lgstrtp-@GST_MAJORMINOR@ -lgstrtsp-@GST_MAJORMINOR@ \
-lgstsdp-@GST_MAJORMINOR@ $(GST_LIBS) $(LIBM)
-libgstrtspserver_la_LIBTOOLFLAGS = --tag=disable-static
+libgstrtspserver_@GST_MAJORMINOR@_la_LIBTOOLFLAGS = --tag=disable-static
-libgstrtspserver_includedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/rtsp-server
-libgstrtspserver_include_HEADERS = $(public_headers)
+libgstrtspserver_@GST_MAJORMINOR@includedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/rtsp-server
+libgstrtspserver_@GST_MAJORMINOR@include_HEADERS = $(public_headers)