summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index cc0bcac38..d513e13be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,11 @@ AM_MAINTAINER_MODE
dnl sets host_* variables
AC_CANONICAL_HOST
+dnl use pretty build output with automake >= 1.11
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])],
+ [AM_DEFAULT_VERBOSITY=1
+ AC_SUBST(AM_DEFAULT_VERBOSITY)])
+
dnl our libraries and install dirs use major.minor as a version
GST_MAJORMINOR=$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR
dnl we override it here if we need to for the release candidate of new series
@@ -822,14 +827,10 @@ dnl whatevertarget_LIBS and -L flags here affect the rest of the linking
GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*gst_plugin_desc\$\$' $GST_ALL_LDFLAGS"
AC_SUBST(GST_PLUGIN_LDFLAGS)
-SHAVE_INIT([common],[enable])
-
dnl *** output files ***
AC_CONFIG_FILES(
Makefile
-common/shave
-common/shave-libtool
gst-plugins-base.spec
gst/Makefile
gst/adder/Makefile