summaryrefslogtreecommitdiff
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-20 20:25:24 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-20 20:25:24 +0000
commit476c37eb4548d39f8ea1e939bd7cfad842beda96 (patch)
treeee194825c966344883429311cf0724f4c99ba0fe /sys/Makefile.am
parent759523103767794381baf58b1ab8fbdd2bbf0f26 (diff)
unforming dir names
Original commit message from CVS: unforming dir names
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 101ea5a51..98297dc5a 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -1,5 +1,17 @@
-### use HAVE_ stuff to decide on dirs
-DIRS=qcam v4l vcdsrc vgasink xvideosink
+### FIXME use HAVE_ stuff to decide on dirs
+if USE_VGA
+VGA_SUBDS=vga
+else
+VGA_SUBDS=
+endif
-DIST_SUBDIRS=qcam v4l vcdsrc vgasink xvideosink
+if USE_OSS
+OSS_SUBDS=oss
+else
+OSS_SUBDS=
+endif
+
+SUBDIRS=$(OSS_SUBDS) qcam v4l vcd $(VGA_SUBDS) xvideo
+
+DIST_SUBDIRS=oss qcam v4l vcd vga xvideo