summaryrefslogtreecommitdiff
path: root/gst/playback/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2007-05-17 15:22:44 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-05-17 15:22:44 +0000
commitd33939800dd8792d761454fb8974af8f33e8bd9b (patch)
tree461ed9c65f85e1df829ee9df0ea62e4d5fbbeb4c /gst/playback/Makefile.am
parent23396338ad362df01117ffce84119fa6f17019bc (diff)
gst/playback/gstqueue2.c: Tweak the buffering thresholds a little.
Original commit message from CVS: * gst/playback/gstqueue2.c: (update_rates): Tweak the buffering thresholds a little. Update the buffer size with the previously calculate rate instead of only when we calculate a new rate so that we get smoother buffering updates. * gst/playback/Makefile.am: * gst/playback/gsturidecodebin.c: (gst_uri_decode_bin_base_init), (gst_uri_decode_bin_class_init), (gst_uri_decode_bin_init), (gst_uri_decode_bin_finalize), (gst_uri_decode_bin_set_property), (gst_uri_decode_bin_get_property), (unknown_type), (add_element_stream), (no_more_pads_full), (no_more_pads), (source_no_more_pads), (new_decoded_pad), (array_has_value), (gen_source_element), (has_all_raw_caps), (analyse_source), (remove_decoders), (make_decoder), (remove_source), (source_new_pad), (setup_source), (decoder_query_init), (decoder_query_duration_fold), (decoder_query_duration_done), (decoder_query_position_fold), (decoder_query_position_done), (decoder_query_latency_fold), (decoder_query_latency_done), (decoder_query_seeking_fold), (decoder_query_seeking_done), (decoder_query_generic_fold), (gst_uri_decode_bin_query), (gst_uri_decode_bin_change_state), (plugin_init): New element that intergrates a source, optional buffering element and decodebin.
Diffstat (limited to 'gst/playback/Makefile.am')
-rw-r--r--gst/playback/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/gst/playback/Makefile.am b/gst/playback/Makefile.am
index 69da17bc6..87b485520 100644
--- a/gst/playback/Makefile.am
+++ b/gst/playback/Makefile.am
@@ -7,7 +7,8 @@ built_headers = gstplay-marshal.h
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
-plugin_LTLIBRARIES = libgstplaybin.la libgstdecodebin.la libgstdecodebin2.la libgstqueue2.la
+plugin_LTLIBRARIES = libgstplaybin.la libgstdecodebin.la libgstdecodebin2.la libgstqueue2.la \
+ libgsturidecodebin.la
libgstplaybin_la_SOURCES = \
gstplaybin.c \
@@ -44,6 +45,14 @@ libgstqueue2_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
libgstqueue2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstqueue2_la_LIBADD = $(GST_LIBS)
+libgsturidecodebin_la_SOURCES = gsturidecodebin.c
+nodist_libgsturidecodebin_la_SOURCES = $(built_sources)
+libgsturidecodebin_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+libgsturidecodebin_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgsturidecodebin_la_LIBADD = \
+ $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
+ $(GST_LIBS)
+
noinst_HEADERS = \
gstplaybasebin.h \
gststreaminfo.h \