summaryrefslogtreecommitdiff
path: root/gst/playback/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2011-03-25 08:26:00 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2011-05-14 11:42:32 +0200
commit2f8467d68249e8d1a28b7bbd9c53b56a8c26ba4b (patch)
tree2d677e4375a5a23fc6878f2889436f2e46684eee /gst/playback/Makefile.am
parent105da803ade859fb299ed3c5265d6acdd168ca8f (diff)
playsink: Add audio and video converter convenience bins
These reconfigure based on the caps and plugin in converters if necessary. This also makes switching between compressed and raw streams work flawlessly without loosing the states of any element somewhere or having running time problems.
Diffstat (limited to 'gst/playback/Makefile.am')
-rw-r--r--gst/playback/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gst/playback/Makefile.am b/gst/playback/Makefile.am
index 3adb56db7..2fe90e6e8 100644
--- a/gst/playback/Makefile.am
+++ b/gst/playback/Makefile.am
@@ -18,6 +18,8 @@ libgstplaybin_la_SOURCES = \
gststreaminfo.c \
gststreamselector.c \
gstsubtitleoverlay.c \
+ gstplaysinkvideoconvert.c \
+ gstplaysinkaudioconvert.c \
gststreamsynchronizer.c
nodist_libgstplaybin_la_SOURCES = $(built_sources)
@@ -57,6 +59,8 @@ noinst_HEADERS = \
gststreamselector.h \
gstrawcaps.h \
gstsubtitleoverlay.h \
+ gstplaysinkvideoconvert.h \
+ gstplaysinkaudioconvert.h \
gststreamsynchronizer.h
BUILT_SOURCES = $(built_headers) $(built_sources)