summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2009-08-23 00:40:59 -0700
committerMarcel Holtmann <marcel@holtmann.org>2009-08-23 00:40:59 -0700
commita5b1e3d02c8b356bb167dd7e4b6ab54edf271e7b (patch)
tree12e4d0f016fd1fe85e71fe76267673bb04a63ce5 /configure.ac
parentd015dc8986f8548653160bc9ee6c8fef126dd8e8 (diff)
Switch to a full non-recursive build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 4 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index c020aeec..48ca425d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
AC_PREREQ(2.60)
AC_INIT(bluez, 4.48)
-AM_INIT_AUTOMAKE()
+AM_INIT_AUTOMAKE([foreign subdir-objects])
AM_CONFIG_HEADER(config.h)
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -17,6 +17,7 @@ COMPILER_FLAGS
AC_LANG_C
AC_PROG_CC
+AM_PROG_CC_C_O
AC_PROG_CC_PIE
AC_PROG_INSTALL
AC_PROG_YACC
@@ -28,8 +29,6 @@ m4_ifdef([AC_LIBTOOL_TAGS], [AC_LIBTOOL_TAGS([])])
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
-GTK_DOC_CHECK
-
AC_FUNC_PPOLL
AC_CHECK_LIB(dl, dlopen, dummy=yes,
@@ -45,30 +44,5 @@ AC_PATH_SNDFILE
AC_ARG_BLUEZ
-AC_OUTPUT([
- Makefile
- include/Makefile
- lib/Makefile
- gdbus/Makefile
- common/Makefile
- sbc/Makefile
- src/Makefile
- test/Makefile
- cups/Makefile
- tools/Makefile
- client/Makefile
- rfcomm/Makefile
- compat/Makefile
- plugins/Makefile
- network/Makefile
- serial/Makefile
- input/Makefile
- audio/Makefile
- scripts/Makefile
- scripts/bluetooth.rules
- doc/Makefile
- doc/version.xml
- src/bluetoothd.8
- src/hcid.conf.5
- bluez.pc
-])
+AC_OUTPUT(Makefile scripts/bluetooth.rules doc/version.xml
+ src/bluetoothd.8 src/hcid.conf.5 bluez.pc)