summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRyan C. Gordon <icculus@icculus.org>2018-11-02 21:34:17 -0400
committerRyan C. Gordon <icculus@icculus.org>2018-11-02 21:34:17 -0400
commitfeb85d5ae0ef4c3e5602cfc4976f7a97f049ff2c (patch)
treee3b7981a6001604bf0ff6cd8fe8517dddb26d682 /CMakeLists.txt
parentf5eeebbe656b6cfa69bd44f68bbff6a820c08ae0 (diff)
mir: Removed mir client support.
Fixes Bugzilla #4288.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0128c7ac7d..13df80e095 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -326,8 +326,6 @@ set_option(VIDEO_X11 "Use X11 video driver" ${UNIX_SYS})
set_option(VIDEO_WAYLAND "Use Wayland video driver" ${UNIX_SYS})
dep_option(WAYLAND_SHARED "Dynamically load Wayland support" ON "VIDEO_WAYLAND" OFF)
dep_option(VIDEO_WAYLAND_QT_TOUCH "QtWayland server support for Wayland video driver" ON "VIDEO_WAYLAND" OFF)
-set_option(VIDEO_MIR "Use Mir video driver" ${UNIX_SYS})
-dep_option(MIR_SHARED "Dynamically load Mir support" ON "VIDEO_MIR" OFF)
set_option(VIDEO_RPI "Use Raspberry Pi video driver" ${UNIX_SYS})
dep_option(X11_SHARED "Dynamically load X11 support" ON "VIDEO_X11" OFF)
set(SDL_X11_OPTIONS Xcursor Xinerama XInput Xrandr Xscrnsaver XShape Xvm)
@@ -997,7 +995,6 @@ elseif(UNIX AND NOT APPLE AND NOT ANDROID)
# Need to check for Raspberry PI first and add platform specific compiler flags, otherwise the test for GLES fails!
CheckRPI()
CheckX11()
- CheckMir()
CheckDirectFB()
CheckOpenGLX11()
CheckOpenGLESX11()