summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Lantinga <slouken@libsdl.org>2018-08-21 12:11:34 -0700
committerSam Lantinga <slouken@libsdl.org>2018-08-21 12:11:34 -0700
commit6a6db94f54c944ce8ac76424fb18d544f38818b5 (patch)
tree2c5a7ffebfbc22130434d510a4700ca32e15580a /CMakeLists.txt
parentabed52cd4a3c00bca8bd9aa48c6ec5338f38e0dd (diff)
First pass on the new SDL sensor API
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 492a5d0ede..9333b3cda3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -750,6 +750,10 @@ if(SDL_HAPTIC)
file(GLOB HAPTIC_SOURCES ${SDL2_SOURCE_DIR}/src/haptic/*.c)
set(SOURCE_FILES ${SOURCE_FILES} ${HAPTIC_SOURCES})
endif()
+if(SDL_SENSOR)
+ file(GLOB SENSOR_SOURCES ${SDL2_SOURCE_DIR}/src/sensor/*.c)
+ set(SOURCE_FILES ${SOURCE_FILES} ${SENSOR_SOURCES})
+endif()
if(SDL_POWER)
file(GLOB POWER_SOURCES ${SDL2_SOURCE_DIR}/src/power/*.c)
set(SOURCE_FILES ${SOURCE_FILES} ${POWER_SOURCES})