summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Novichkov <admin@wohlnet.ru>2018-06-29 18:29:17 +0300
committerVitaly Novichkov <admin@wohlnet.ru>2018-06-29 18:29:17 +0300
commit67c50873709ee7a452090b18fca740f9f64d5e53 (patch)
treeade6a2d1843f1cbd47d44ae9056e36bd0feb0b3a /CMakeLists.txt
parent9d011323c0bf97ae4c291fce54ae3ee43d4139c2 (diff)
Remove "lib" prefix from DLL file on MinGW builds
closes bug #4209.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd6783836b..5b0f7f8b85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -210,6 +210,12 @@ endif()
set(SDL_LIBS "-lSDL2")
set(SDL_CFLAGS "")
+# When building shared lib for Windows with MinGW,
+# avoid the DLL having a "lib" prefix
+if(WIN32)
+ set(CMAKE_SHARED_LIBRARY_PREFIX "")
+endif()
+
# Emscripten toolchain has a nonempty default value for this, and the checks
# in this file need to change that, so remember the original value, and
# restore back to that afterwards. For check_function_exists() to work in