summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRyan C. Gordon <icculus@icculus.org>2013-07-07 02:03:07 -0400
committerRyan C. Gordon <icculus@icculus.org>2013-07-07 02:03:07 -0400
commit61740135226c71ea61e738ef1d774f227c7f1d25 (patch)
treecf9f8c3dda8e1a12701b7cc8779cde3844dd3a93 /CMakeLists.txt
parent69f525600ab7e1c2319f8bdd9dcf18dad9cb252f (diff)
Added an SDL2 OpenBSD sndio(7) audio target.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf3f34a4cf..a649fb7a09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,6 +203,7 @@ dep_option(PULSEAUDIO_SHARED "Dynamically load PulseAudio support" ON "PULSEAU
set_option(ARTS "Support the Analog Real Time Synthesizer" ${UNIX_SYS})
dep_option(ARTS_SHARED "Dynamically load aRts audio support" ON "ARTS" OFF)
set_option(NAS "Support the NAS audio API" ${UNIX_SYS})
+set_option(SNDIO "Support the sndio audio API" ${UNIX_SYS})
set_option(RPATH "Use an rpath when linking SDL" ${UNIX_SYS})
set_option(CLOCK_GETTIME "Use clock_gettime() instead of gettimeofday()" OFF)
set_option(INPUT_TSLIB "Use the Touchscreen library for input" ${UNIX_SYS})
@@ -621,6 +622,7 @@ if(UNIX AND NOT APPLE)
CheckESD()
CheckARTS()
CheckNAS()
+ CheckSNDIO()
CheckFusionSound()
endif(SDL_AUDIO)