summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Lantinga <slouken@libsdl.org>2017-11-04 15:34:14 -0700
committerSam Lantinga <slouken@libsdl.org>2017-11-04 15:34:14 -0700
commit48bcdfd8cc3db5b100e06ca9d5cdcedd4b46a35a (patch)
tree242419b5ea9f870eb6e31c6ee92fb083d498f01e /CMakeLists.txt
parent325dff1cb1a34eb3f0f46e52c27a7bf8a3067211 (diff)
Added float versions of SDL's math functions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73d94077fb..16141a51eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -637,8 +637,10 @@ if(LIBC)
wcslen wcscmp
strlen _strrev _strupr _strlwr strchr strrchr strstr itoa _ltoa
_ultoa strtol strtoul strtoll strtod atoi atof strcmp strncmp
- _stricmp _strnicmp sscanf atan atan2 acos asin ceil copysign cos
- cosf fabs floor log pow scalbn sin sinf sqrt sqrtf tan tanf)
+ _stricmp _strnicmp sscanf
+ acos acosf asin asinf atan atanf atan2 atan2f ceil ceilf
+ copysign copysignf cos cosf fabs fabsf floor floorf log logf
+ pow powf scalbn scalbnf sin sinf sqrt sqrtf tan tanf)
string(TOUPPER ${_FN} _UPPER)
set(HAVE_${_UPPER} 1)
endforeach()