summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2009-10-21 21:49:50 +0300
committerRalf Habacker <ralf.habacker@freenet.de>2009-12-01 09:20:31 +0100
commiteab064cfc4f0dbb41c9d54fbfa7e6537d2e7dc05 (patch)
tree603e952ea71c87c19818bb8d16f8fd9661b991df /configure.in
parent7b29b5dee73b6887c0066625f75ca3031a676dff (diff)
Don't use -fPIC and -fPIE on Windows
The MinGW compiler recognizes them but emits a warning "-fPIC ignored for target (all code is position independent)"
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2c74f61a..30b72522 100644
--- a/configure.in
+++ b/configure.in
@@ -1093,7 +1093,7 @@ if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-fPIC[\ \ ]*) ;;
- *) if cc_supports_flag -fPIC; then
+ *) if test x$dbus_win = xno && cc_supports_flag -fPIC; then
PIC_CFLAGS="-fPIC"
if ld_supports_flag -z,relro; then
PIC_LDFLAGS="-Wl,-z,relro"
@@ -1104,7 +1104,7 @@ if test "x$GCC" = "xyes"; then
case " $CFLAGS " in
*[\ \ ]-fPIE[\ \ ]*) ;;
- *) if cc_supports_flag -fPIE; then
+ *) if test x$dbus_win = xno && cc_supports_flag -fPIE; then
PIE_CFLAGS="-fPIE"
if ld_supports_flag -z,relro; then
PIE_LDFLAGS="-pie -Wl,-z,relro"