summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 18ed073..94613a3 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -26,6 +26,9 @@
EXTRA_DIST = \
Doxyfile
+if HAVE_DOXYGEN
+all-local: doc
+
doc:
doxygen
@@ -38,6 +41,7 @@ install-data-local:
$(INSTALL) -d $(DESTDIR)$(mandir)/man3; \
$(INSTALL) api/man/man3/* $(DESTDIR)$(mandir)/man3; \
fi
+endif
clean-local:
-rm -rf *.pdf *.html api