summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9451d8f..b8ad878 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,19 +18,14 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+SHARED_DIR = $(top_srcdir)/shared
-# this is obnoxious:
-# -module lets us name the module exactly how we want
-# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
-# _ladir passes a dummy rpath to libtool so the thing will actually link
-# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
@DRIVER_NAME@_drv_la_LDFLAGS = -module -avoid-version
+@DRIVER_NAME@_drv_la_LIBADD = $(SHARED_DIR)/lib@DRIVER_NAME@.la
@DRIVER_NAME@_drv_ladir = @inputdir@
-INCLUDES = -I$(srcdir)
+INCLUDES = -I$(SHARED_DIR)
-@DRIVER_NAME@_drv_la_SOURCES = @DRIVER_NAME@.c @DRIVER_NAME@_defs.h \
- @DRIVER_NAME@_client.c @DRIVER_NAME@_client.h \
- @DRIVER_NAME@_proto.c @DRIVER_NAME@_proto.h
+@DRIVER_NAME@_drv_la_SOURCES = @DRIVER_NAME@.c