summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2006-04-18 22:08:10 +0000
committerRay Strode <rstrode@redhat.com>2006-04-18 22:08:10 +0000
commita41d9e0323054501356beccde6321268372eb237 (patch)
treeb921186f5c3c753c31e7713ba38ef7af4aa9789c /src/Makefile.am
parente0d6b8a0dd16fed932d287990b44261c5fe087eb (diff)
Validate that desktop file categories match those specified in the spec.
2006-04-18 Ray Strode <rstrode@redhat.com> Validate that desktop file categories match those specified in the spec. Patch from Emmet Hikory <emmet.hikory@gmail.com> and Vincent Untz <vuntz@gnome.org> (bug 3337786) * src/validate.c (validate_categories): new function to ensure that categories are known. 2006-04-18 Vincent Untz <vuntz@gnome.org> Use GKeyFile instead and kill egg-* usage (bug 319987). * src/Makefile.am: remove egg-* * src/update-desktop-database.c: (process_desktop_file): use GKeyFile (get_default_search_path): use g_get_system_data_dirs() 2006-04-18 Vincent Untz <vuntz@gnome.org> Port to GOption (bug 338575) * configure.in: remove the check for popt, depend on glib >= 2.6.0 * src/install.c: (parse_options_callback): rewritten (main): port to GOption * src/update-desktop-database.c: (sync_database): remove warning (main): port to GOption
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6904a9e..868bde7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,12 +24,7 @@ desktop_file_install_SOURCES= \
install.c
update_desktop_database_SOURCES = \
- update-desktop-database.c \
- eggdesktopentries.c \
- eggdesktopentries.h \
- eggintl.h \
- eggdirfuncs.c \
- eggdirfuncs.h
+ update-desktop-database.c
desktop_file_validate_LDADD = $(DESKTOP_FILE_UTILS_LIBS)
desktop_file_install_LDADD = $(DESKTOP_FILE_UTILS_LIBS)