summaryrefslogtreecommitdiff
path: root/xkb/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
commitded56b1a74e6b3e4c48054b7e142d924b19e6104 (patch)
treec2c9fb687494f559cb19e317290e272849c391ae /xkb/Makefile.am
parentaabb868920658c9d3979dc194c6bd9702171f101 (diff)
Adding initial build system.
Diffstat (limited to 'xkb/Makefile.am')
-rw-r--r--xkb/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/xkb/Makefile.am b/xkb/Makefile.am
new file mode 100644
index 000000000..d02a446a0
--- /dev/null
+++ b/xkb/Makefile.am
@@ -0,0 +1,51 @@
+noinst_LTLIBRARIES = libxkb.la
+
+DDX_SRCS = \
+ ddxBeep.c \
+ ddxCtrls.c \
+ ddxFakeBtn.c \
+ ddxFakeMtn.c \
+ ddxInit.c \
+ ddxKeyClick.c \
+ ddxKillSrv.c \
+ ddxLEDs.c \
+ ddxVT.c \
+ ddxLoad.c \
+ ddxList.c \
+ ddxConfig.c \
+ ddxDevBtn.c \
+ ddxPrivate.c
+
+DIX_SRCS = \
+ xkb.c \
+ xkbUtils.c \
+ xkbEvents.c \
+ xkbAccessX.c \
+ xkbSwap.c \
+ xkbLEDs.c \
+ xkbInit.c \
+ xkbActions.c \
+ xkbPrKeyEv.c
+
+# this should be replaced by a common library or something, ideally -d
+XKBFILE_SRCS = \
+ maprules.c \
+ xkmread.c \
+ xkbtext.c \
+ xkbfmisc.c \
+ xkberrs.c \
+ xkbconfig.c \
+ xkbout.c
+
+X11_SRCS = \
+ XKBMisc.c \
+ XKBAlloc.c \
+ XKBGAlloc.c \
+ XKBMAlloc.c
+
+XI_SRCS = xkbPrOtherEv.c
+
+libxkb_la_SOURCES = $(DDX_SRCS) $(DIX_SRCS) $(XI_SRCS) $(XKBFILE_SRCS) \
+ $(X11_SRCS)
+
+EXTRA_DIST = xkb.h xkbDflts.h