summaryrefslogtreecommitdiff
path: root/Xext/Makefile.am
diff options
context:
space:
mode:
authorEamon Walsh <ewalsh@tycho.nsa.gov>2006-09-08 15:31:18 -0400
committerEamon Walsh <ewalsh@moss-uranus.epoch.ncsc.mil>2006-12-12 13:27:03 -0500
commit7f16c38ae2b47b195609d8fedefb7b28f612b2d4 (patch)
tree5560d90355e00cb49ed46bc0fd342ab277054f47 /Xext/Makefile.am
parenta7f4bbea87ada1d699bfd9e3b6a98f06191650f6 (diff)
Add SELinux extension configure-time support.
Diffstat (limited to 'Xext/Makefile.am')
-rw-r--r--Xext/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Xext/Makefile.am b/Xext/Makefile.am
index 6ea3d7445..be04c849a 100644
--- a/Xext/Makefile.am
+++ b/Xext/Makefile.am
@@ -76,6 +76,16 @@ if XACE
BUILTIN_SRCS += $(XACE_SRCS)
endif
+# SELinux extension: provides SELinux policy support for X objects
+# requires X-ACE extension
+XSELINUX_SRCS = xselinux.c xselinux.h
+if XSELINUX
+BUILTIN_SRCS += $(XSELINUX_SRCS)
+
+SERVERCONFIG_DATA += XSELinuxConfig
+AM_CFLAGS += -DXSELINUXCONFIGFILE=\"$(SERVERCONFIGdir)/XSELinuxConfig\"
+endif
+
# Security extension: multi-level security to protect clients from each other
XCSECURITY_SRCS = security.c securitysrv.h
if XCSECURITY