summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorScott Moreau <oreaus@gmail.com>2012-05-27 14:25:02 -0600
committerKristian Høgsberg <krh@bitplanet.net>2012-05-31 13:10:22 -0400
commit7a1b32a19888bb4f4a47dc951cf5d72db0899c11 (patch)
tree47498c34e446f9ce7899b99e3d29b124192b57cf /src/Makefile.am
parentd64bdf4755005854fc59922ed0e4cbf12ebfbdac (diff)
Implement text cursor position protocol.
Here we create a new client/compositor interface in weston to allow clients to report their x/y cursor position to the compositor. These values are then used to center the zoom area on this point. This is useful for everyone, especially people who are visually impaired.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 52457ac..7606211 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,9 @@ weston_SOURCES = \
screenshooter.c \
screenshooter-protocol.c \
screenshooter-server-protocol.h \
+ text-cursor-position.c \
+ text-cursor-position-protocol.c \
+ text-cursor-position-server-protocol.h \
util.c \
matrix.c \
matrix.h \
@@ -144,6 +147,8 @@ endif
BUILT_SOURCES = \
screenshooter-server-protocol.h \
screenshooter-protocol.c \
+ text-cursor-position-server-protocol.h \
+ text-cursor-position-protocol.c \
tablet-shell-protocol.c \
tablet-shell-server-protocol.h \
desktop-shell-protocol.c \