summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-06-01 12:20:25 +0300
committerKristian Høgsberg <krh@bitplanet.net>2012-06-01 10:32:39 -0400
commit15643f627df36635568a5c93d0b101a6cfc5efb9 (patch)
tree4d65570bff0af5a1dddc5d0dec8dcfe7073ad9f0 /src/Makefile.am
parentd95222e56f79c0602ab542300e0adf0c415cfaee (diff)
build: introduce GCC_CXXFLAGS
The patch "compositor-android: fix build flags" started using GCC_CFLAGS for C++ files, too. That lead to the following warnings when building a C++ file: cc1plus: warning: command line option "-Wstrict-prototypes" is valid for Ada/C/ObjC but not for C++ cc1plus: warning: command line option "-Wmissing-prototypes" is valid for Ada/C/ObjC but not for C++ Introduce GCC_CXXFLAGS, similar to GCC_CFLAGS, but for C++, avoiding the problematic compiler flags. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fd8aa9b..64932a1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -130,7 +130,7 @@ android_backend = android-backend.la
android_backend_la_LDFLAGS = -module -avoid-version
android_backend_la_LIBADD = $(COMPOSITOR_LIBS)
android_backend_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
-android_backend_la_CXXFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
+android_backend_la_CXXFLAGS = $(GCC_CXXFLAGS) $(COMPOSITOR_CFLAGS)
android_backend_la_SOURCES = \
compositor-android.c \
android-framebuffer.cpp \