summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlberto Garcia <agarcia@igalia.com>2011-07-01 17:14:10 +0300
committerJuan A. Suarez Romero <jasuarez@igalia.com>2011-07-01 16:39:44 +0200
commitf987118805146a778f054332ed65418c6b8ecce5 (patch)
treecebfc6524f44ecefc8f0bcc06b3478a2e533af33 /Makefile.am
parent219daf4829dbd909edaafd822937f417b7fe0813 (diff)
doc: Generate a ChangeLog file from git when running make dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ba3d7b9..a466e11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,3 +51,16 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
distclean-local:
-rm -rf autom4te.cache
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi