summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2013-08-13 20:02:22 +0200
committerJuan A. Suarez Romero <jasuarez@igalia.com>2013-08-24 00:59:28 +0200
commit99d47217a1f543ae3ddc23788dfa673ecae7fd93 (patch)
tree98d83592fc19734fbd69b49639caf7da8a65e674 /Makefile.am
parent18da634b72c5670fb96bbbc4af70a868adb040a2 (diff)
build: Switch to git.mk to keep the .gitignore file updated
Fixing the *CLEANFILES lists where needed and having git.mk generate the .gitignore files automatically seemed more useful than manually updating those files. https://bugzilla.gnome.org/show_bug.cgi?id=706491
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 10 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fb95c9..c05000b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,21 +27,14 @@ endif
dist_man1_MANS = grl-inspect.1
MAINTAINERCLEANFILES = \
- aclocal.m4 \
- compile \
- config.guess \
- config.sub \
- configure \
- depcomp \
- install-sh \
- ltmain.sh \
- missing \
- libtool \
- stamp-h1 \
- Makefile.in \
- *.make \
- mkinstalldirs \
- *~
+ $(GITIGNORE_MAINTAINERCLEANFILES_TOPLEVEL) \
+ $(GITIGNORE_MAINTAINERCLEANFILES_M4_LIBTOOL) \
+ $(GITIGNORE_MAINTAINERCLEANFILES_MAKEFILE_IN) \
+ $(srcdir)/gtk-doc.make \
+ $(srcdir)/m4/gtk-doc.m4 \
+ $(srcdir)/m4/intltool.m4 \
+ $(srcdir)/omf.make \
+ $(srcdir)/xmldocs.make
DISTCLEANFILES = $(MAINTAINERCLEANFILES)
@@ -64,3 +57,5 @@ dist-hook:
else \
echo A git clone is required to generate a ChangeLog >&2; \
fi
+
+-include $(top_srcdir)/git.mk