summaryrefslogtreecommitdiff
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Halse Rogers <christopher.halse.rogers@canonical.com>2012-07-19 12:30:10 +1000
committerMatt Turner <mattst88@gmail.com>2012-08-13 12:24:39 -0700
commit77a3efc6b907943903190b385fdf107c4acfcdca (patch)
tree71a436d544cbef3ef5ad102097a9049f39413ddd /src/glsl/Makefile.am
parent37a1b8083e7f7a6c3abe3843cfaed84163f2d19f (diff)
build/glsl: fix location of generated files.
Like in src/mesa, use GLSL_BUILDDIR/GLSL_SRCDIR to unambiguously distinguish between in-tree and generated files. Reviewed-by: Eric Anholt <eric@anholt.net> Signed-off-by: Christopher James Halse Rogers <christopher.halse.rogers@canonical.com>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index d86153c48b..0ab6672114 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -23,9 +23,6 @@
# builtin_compiler is built before libglsl to generate builtin_function.cpp for libglsl.
# For this to work, a dummy version of builtin_function.cpp, builtin_stubs.cpp, is used.
-# Hack to make some of the non-automake variables work.
-TOP=$(top_builddir)
-
AM_CFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/src/mapi \
@@ -39,7 +36,6 @@ AM_CXXFLAGS = $(AM_CFLAGS)
AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
-GLSL_SRCDIR=$(top_srcdir)/src/glsl
include Makefile.sources
noinst_LTLIBRARIES = libglslcommon.la libglsl.la