summaryrefslogtreecommitdiff
path: root/tests/egl/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@intel.com>2011-02-25 12:33:15 -0800
committerChad Versace <chad.versace@intel.com>2011-02-25 20:44:11 -0800
commit6c1e6f71cac85f301eee63485266c5757541292d (patch)
tree8061a3b39ce0d05c3e5709bf67b17fc4935610f9 /tests/egl/CMakeLists.txt
parentfca0133f7d1aec646cf2a994460b2a5ef0072422 (diff)
cmake: Each CMakeLists.txt that produces a target, rename to CMakeLists.gl.txt
In preparation for adding GLES2 targets to Piglit, it is necessary to compartmentalize the GL targets and the GLES2 targets (of which none yet exist) in API-specific CMake files. Since all CMake targets currently use the OpenGL API, achieving compartmentalization is as simple as renaming each CMakeLists.txt. Note: This belongs to a series that adds GLES2 support to Piglit. Signed-off-by: Chad Versace <chad.versace@intel.com>
Diffstat (limited to 'tests/egl/CMakeLists.txt')
-rw-r--r--tests/egl/CMakeLists.txt28
1 files changed, 1 insertions, 27 deletions
diff --git a/tests/egl/CMakeLists.txt b/tests/egl/CMakeLists.txt
index 0458ea5cb..144a306f4 100644
--- a/tests/egl/CMakeLists.txt
+++ b/tests/egl/CMakeLists.txt
@@ -1,27 +1 @@
-
-include_directories(
- ${OPENGL_INCLUDE_PATH}
- ${GLUT_INCLUDE_DIR}
- ${piglit_SOURCE_DIR}/tests/util
-)
-
-link_libraries (
- piglitutil
- ${OPENGL_gl_LIBRARY}
- ${OPENGL_glu_LIBRARY}
- ${OPENGL_egl_LIBRARY}
- ${GLUT_glut_LIBRARY}
- ${TIFF_LIBRARY}
-)
-
-IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- add_executable (egl-nok-swap-region egl-util.c egl-nok-swap-region.c)
- target_link_libraries(egl-nok-swap-region pthread X11)
-
- add_executable (egl-nok-texture-from-pixmap egl-util.c egl-nok-texture-from-pixmap.c)
- target_link_libraries(egl-nok-texture-from-pixmap pthread X11)
-
- add_executable (egl-create-surface egl-util.c egl-create-surface.c)
- target_link_libraries(egl-create-surface pthread X11)
-
-ENDIF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+piglit_include_target_api()