summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVinson Lee <vlee@freedesktop.org>2014-11-08 13:51:10 -0800
committerVinson Lee <vlee@freedesktop.org>2014-11-08 13:51:10 -0800
commita4f0342dbdbaec97d35442876efce3bd53390f5a (patch)
treec2b30cc35e1da0426fce0d4ab872b99b1451d134 /CMakeLists.txt
parentd052e50c5e78eca69eb950671d943e2811d431fb (diff)
cmake: Fix GCC -Wvla flag check.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=86045 Signed-off-by: Vinson Lee <vlee@freedesktop.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1792d05f..2f1597166 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -223,8 +223,8 @@ if (NOT MSVC)
IF (C_COMPILER_FLAG_WDECL_AFTER_STMT)
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wdeclaration-after-statement")
ENDIF ()
- CHECK_C_COMPILER_FLAG("-Wvla" C_COMPILER_FLAG_WDECL_AFTER_STMT)
- IF (C_COMPILER_FLAG_WDECL_AFTER_STMT)
+ CHECK_C_COMPILER_FLAG("-Wvla" C_COMPILER_FLAG_WVLA)
+ IF (C_COMPILER_FLAG_WVLA)
SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wvla")
ENDIF ()