summaryrefslogtreecommitdiff
path: root/tests/examples/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-03-21 17:25:22 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-03-21 17:25:22 +0000
commit94cb0d62f04f4547f31c124a19c5b7c747e9c3cf (patch)
treeaca2ee4f64770782ca74c86a57080b0e3fa0bdf9 /tests/examples/Makefile.am
parente5b9797af61e3018f5305df1dbe8ffea25dbb769 (diff)
gst/Makefile.am
Original commit message from CVS: * gst/Makefile.am * tests/examples/Makefile.am: fix --disable-parse build
Diffstat (limited to 'tests/examples/Makefile.am')
-rw-r--r--tests/examples/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/tests/examples/Makefile.am b/tests/examples/Makefile.am
index e62913990..a08128df0 100644
--- a/tests/examples/Makefile.am
+++ b/tests/examples/Makefile.am
@@ -4,10 +4,15 @@ else
GST_LOADSAVE_DIRS = xml typefind
endif
-dirs = \
+if GST_DISABLE_PARSE
+GST_PARSE_DIRS =
+else
+GST_PARSE_DIRS = launch
+endif
+
+always_dirs = \
controller \
helloworld \
- launch \
metadata \
queue
@@ -27,7 +32,9 @@ dirs = \
#retag
#thread
-SUBDIRS = $(dirs) \
+SUBDIRS = \
+ $(always_dirs) \
+ $(GST_PARSE_DIRS) \
$(GST_LOADSAVE_DIRS)
-DIST_SUBDIRS = $(dirs) xml typefind
+DIST_SUBDIRS = $(always_dirs) xml typefind launch