summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2001-12-23 05:59:38 +0000
committerAndy Wingo <wingo@pobox.com>2001-12-23 05:59:38 +0000
commit6bb3f78a0c4ff63f46db279ad90eca2a8ee2c335 (patch)
treeb47a63beb54f92e909e3173c7c40e187dd6d839e /Makefile.am
parent7aa5885df577d8effb0a3e2fb4997faab51bfe19 (diff)
added --disable-plugins option; useful if you are making the switch to gst-plugins
Original commit message from CVS: added --disable-plugins option; useful if you are making the switch to gst-plugins
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bf329f326..41f0641eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,13 @@ else
SUBDIRS_EXAMPLES =
endif
-SUBDIRS = include gst libs plugins tools $(SUBDIRS_TESTS) $(SUBDIRS_EXAMPLES) \
+if BUILD_PLUGINS
+SUBDIRS_PLUGINS = plugins
+else
+SUBDIRS_PLUGINS =
+endif
+
+SUBDIRS = include gst libs $(SUBDIRS_PLUGINS) tools $(SUBDIRS_TESTS) $(SUBDIRS_EXAMPLES) \
$(SUBDIRS_LGG) $(SUBDIRS_DOCS)
# These are all the possible subdirs