summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d088843c..f63393592 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,3 +61,22 @@ win32-update:
for f in $(WIN32_COPY); do cp $$f win32/common;done
include $(top_srcdir)/common/coverage/lcov.mak
+
+# make sure all symbols we export on linux are defined in the win32 .def too
+# (don't care about other unixes for now, it's enough if it works on one of
+# the linux build bots; we assume .so )
+baselibs='libgstaudio libgstrtp libgstpbutils libgsttag libgstnetbuffer \
+libgstinterfaces libgstvideo libgstriff libgstrtsp libgstcdda'
+check-exports:
+ for l in `eval echo $(baselibs)`; do \
+ libso=`find "$(top_builddir)" -name "$$l-0.10.so"`; \
+ libdef="$(top_srcdir)/win32/common/$$l.def"; \
+ if test "x$$libso" != "x"; then \
+ echo Checking symbols in $$libso; \
+ $(top_srcdir)/common/check-exports $$libdef $$libso || exit 1; \
+ fi; \
+ done
+
+check: check-exports
+
+