summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2012-06-21 11:31:45 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2012-06-21 11:31:45 +0200
commit0bb7ed936354a776cb10582090310efb915911ac (patch)
tree7988625888c801b053a83925f20f627951ab8a69 /configure.ac
parenta095f4806e3b75c717a3b8b728c412443ab6d780 (diff)
Add configure --enable-debug
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b5f498..af25a99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,11 @@ AM_PROG_CC_C_O
AC_PROG_INSTALL
AC_CHECK_TOOL(WINDRES, [windres])
+AC_ARG_ENABLE([debug],
+ AS_HELP_STRING([--enable-debug], [Enable debugging]))
+
+AM_CONDITIONAL([ENABLE_DEBUG], [test "x$enable_debug" = "xyes"])
+
dnl ---------------------------------------------------------------------------
dnl - Extra verbose warning switches
dnl ---------------------------------------------------------------------------