summaryrefslogtreecommitdiff
path: root/pkcs11/xdg-store/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkcs11/xdg-store/tests/Makefile.am')
-rw-r--r--pkcs11/xdg-store/tests/Makefile.am54
1 files changed, 0 insertions, 54 deletions
diff --git a/pkcs11/xdg-store/tests/Makefile.am b/pkcs11/xdg-store/tests/Makefile.am
deleted file mode 100644
index 9f4db482..00000000
--- a/pkcs11/xdg-store/tests/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-
-INCLUDES = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -I$(top_srcdir)/pkcs11 \
- -DSRCDIR="\"@abs_srcdir@\"" \
- $(GLIB_CFLAGS) \
- $(LIBGCRYPT_CFLAGS)
-
-LDADD = \
- libgkm-mock-xdg-module.a \
- $(top_builddir)/pkcs11/xdg-store/libgkm-xdg-store.la \
- $(top_builddir)/pkcs11/gkm/libgkm.la \
- $(top_builddir)/egg/libegg.la \
- $(GLIB_LIBS) \
- $(GTHREAD_LIBS) \
- $(LIBGCRYPT_LIBS)
-
-if WITH_P11_TESTS
-CHECK_PROGS = check-xdg-module
-else
-CHECK_PROGS =
-endif
-
-TEST_PROGS = \
- test-xdg-module \
- test-xdg-trust
-
-check_PROGRAMS = $(TEST_PROGS)
-
-test: $(TEST_PROGS) $(CHECK_PROGS)
- gtester --verbose -m $(TEST_MODE) --g-fatal-warnings $(TEST_PROGS)
- @for prog in $(CHECK_PROGS); do SRCDIR='.' ./$$prog || exit 1; done
-
-check-local: test
-
-all-local: $(check_PROGRAMS)
-
-EXTRA_DIST = \
- p11-tests.conf \
- files
-
-noinst_PROGRAMS = \
- frob-trust-file \
- dump-trust-file \
- $(CHECK_PROGS)
-
-check_xdg_module_CFLAGS = $(P11_TESTS_CFLAGS)
-check_xdg_module_LDADD = $(P11_TESTS_LIBS) $(LDADD)
-
-noinst_LIBRARIES = libgkm-mock-xdg-module.a
-
-libgkm_mock_xdg_module_a_SOURCES = \
- mock-xdg-module.c mock-xdg-module.h