summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b6db0ab6..fec35da5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,8 +15,7 @@ SUBDIRS = \
tool \
testing \
$(PAM_DIR) \
- po \
- docs
+ po
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
@@ -28,7 +27,7 @@ EXTRA_DIST = \
HACKING
DISTCHECK_CONFIGURE_FLAGS = \
- --enable-gtk-doc \
+ --enable-doc \
--disable-strict \
--disable-coverage \
--disable-update-mime \
@@ -75,6 +74,18 @@ clear-coverage:
endif
+if ENABLE_DOC
+SUBDIRS += docs
+
+distcheck-hook:
+ @true
+
+else
+distcheck-hook:
+ @echo "*** doc must be enabled (with --enable-doc) in order to make distcheck"
+ @false
+endif
+
upload-release: $(DIST_ARCHIVES)
scp $(DIST_ARCHIVES) master.gnome.org:
ssh master.gnome.org ftpadmin install $(DIST_ARCHIVES)