summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-05-13 22:39:09 +0200
committerStef Walter <stefw@collabora.co.uk>2011-07-08 18:08:41 +0200
commit176924344174f1510c3b5caa52399170d225acfc (patch)
tree55ed7964f608fefce5c53db98ae6434af9ba0455 /configure.ac
parente1e311edaa7c153e9d20ef21c6ce4851b9ee2715 (diff)
Remove support for GTK+2.
* Simplifies things going forward. Now that GTK+3 is in stable distros we can depend on it. * This was raised on the mailing list a while back. https://bugzilla.gnome.org/show_bug.cgi?id=650144
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 2 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 106fe86d..ba5e133b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,8 +24,7 @@ GCK_REVISION=0
GCK_AGE=0
# GCR package versioning
-GCR_MAJOR_GTK2=0
-GCR_MAJOR_GTK3=3
+GCR_MAJOR=3
GCR_MINOR=0
GCR_MICRO=0
@@ -85,38 +84,9 @@ PKG_CHECK_MODULES(GIO, glib-2.0 >= 2.25.0 gio-2.0)
AC_SUBST(GIO_CFLAGS)
AC_SUBST(GIO_LIBS)
-AC_MSG_CHECKING([which GTK+ version to compile against])
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk=2|3],[which GTK+ version to compile against (default: 3)])],
- [case "$with_gtk" in
- 2*|3*) ;;
- *) AC_MSG_ERROR([invalid GTK+ version specified]) ;;
- esac],
- [with_gtk=3])
-AC_MSG_RESULT([$with_gtk])
-
-case "$with_gtk" in
- 2*)
- GCR_MAJOR=$GCR_MAJOR_GTK2
- GCR_VERSION_SUFFIX=
- GTK_API_VERSION=2.0
- GTK_REQUIRED=2.20.0
- with_gtk=2.0
- ;;
- 3*)
- GCR_MAJOR=$GCR_MAJOR_GTK3
- GCR_VERSION_SUFFIX=-$GCR_MAJOR
- GTK_API_VERSION=3.0
- GTK_REQUIRED=2.90.0
- with_gtk=3.0
- ;;
-esac
-
-PKG_CHECK_MODULES(GTK, gtk+-$GTK_API_VERSION >= $GTK_REQUIRED)
+PKG_CHECK_MODULES(GTK, gtk+-3.0 >= 3.0)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
-AC_SUBST(GTK_API_VERSION)
-AM_CONDITIONAL([WITH_GTK3],[test "$with_gtk" = "3.0"])
GETTEXT_PACKAGE=gnome-keyring
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [The gettext domain name])
@@ -704,7 +674,6 @@ AC_SUBST(GCK_MAJOR)
GCR_LT_RELEASE=$GCR_CURRENT:$GCR_REVISION:$GCR_AGE
AC_SUBST(GCR_LT_RELEASE)
AC_SUBST(GCR_MAJOR)
-AC_SUBST(GCR_VERSION_SUFFIX)
AC_SUBST(DAEMON_CFLAGS)
AC_SUBST(DAEMON_LIBS)
@@ -806,7 +775,6 @@ echo "CONFIGURATION"
echo " SSH Agent: $ssh_status"
echo " GPG Agent: $gpg_status"
echo " Root Certificates: $root_status"
-echo " GTK+ Version: $GTK_API_VERSION"
echo " PKCS#11 Modules: $P11_SYSTEM_MODULES"
echo
echo "BUILD"