summaryrefslogtreecommitdiff
path: root/example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/Makefile.am')
-rw-r--r--example/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/example/Makefile.am b/example/Makefile.am
index 2782dfa4..086d694d 100644
--- a/example/Makefile.am
+++ b/example/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2003, 2004, 2005, 2006, 2008, 2009
+# Copyright (C) 2003, 2004, 2005, 2006, 2008, 2009, 2012
# Rocky Bernstein <rocky@gnu.org>
#
# This program is free software: you can redistribute it and/or modify
@@ -50,6 +50,14 @@ noinst_PROGRAMS = \
check_PROGRAMS = cdtext device drives \
mmc1 mmc2 mmc2a mmc3 sample4
+#: run regression tests. "test" is the same thing as "check"
+test: check-am
+
+#: Run all tests without bloated output
+check-short:
+ $(MAKE) check 2>&1 | ruby @abs_top_srcdir@/make-check-filter.rb
+
+
INCLUDES = $(LIBCDIO_CFLAGS)
audio_DEPENDENCIES = $(LIBCDIO_DEPS)